<!DOCTYPE html>
<html lang="en" class="no-js">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="http://digital.vpr.net/post/mitchs-sports-red-sox-power-surge-continues-knights-defy-odds-make-cup-final-inaugural-year" />
<meta property="og:title" content="Mitch&#039;s Sports: Red Sox Power Surge Continues; Knights Defy Odds To Make Cup Final In Inaugural Year" />
<link href="http://mediad.publicbroadcasting.net/spacer.gif" rel="image_src" />
<meta name="description" content="If there were any doubts as to whether the Boston Red Sox have solved their power woes from 2017, when they were last in home runs in the American League," />
<meta property="og:description" content="If there were any doubts as to whether the Boston Red Sox have solved their power woes from 2017, when they were last in home runs in the American League," />
<meta property="og:image" content="http://mediad.publicbroadcasting.net/p/vpr/files/201411/vpr-logo.jpg" />
<meta content="Mitch&amp;#039;s Sports: Red Sox Power Surge Continues; Knights Defy Odds To Make Cup Final In Inaugural Year" about="/post/mitchs-sports-red-sox-power-surge-continues-knights-defy-odds-make-cup-final-inaugural-year" property="dc:title" />
<link rel="shortcut icon" href="http://mediad.publicbroadcasting.net/p/vpr/files/favicon.ico" type="image/vnd.microsoft.icon" />
<meta property="twitter:creator" content="@vprnet" />
<meta property="twitter:site" content="@vprnet" />
<meta property="twitter:card" content="summary" />
<link rel="shortcut icon" href="public://favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="datePublished" content="2018-05-21" />
<meta name="has_audio" content="1" />
<meta name="programs" content="Mitch&#039;s Sports Report, VPR News" />
<link rel="shortlink" href="/node/46106" />
<link rel="canonical" href="/post/mitchs-sports-red-sox-power-surge-continues-knights-defy-odds-make-cup-final-inaugural-year" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="category" content="VPR News" />
<meta name="nid" content="46106" />
<meta name="wordCount" content="1160" />
<meta name="keywords" content="Sports" />
<meta name="org_id" content="0" />
<meta name="author" content="Mitch Wertlieb" />
<meta name="story_id" content="613005223" />
<meta property="fb:pages" content="35976690559" />
    <title>Mitch&#039;s Sports: Red Sox Power Surge Continues; Knights Defy Odds To Make Cup Final In Inaugural Year | Vermont Public Radio</title>
    <link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_zXr1pRkjUmFHX10b6Pv5_DqzyewvdLNQ8QgccGQIRQQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_ZFlaYqkiQzTmlBPX4mQeT33IFQX3nR-zpGlyqFhtTNM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_PV0HBDBtTWS7oiEnFpozcEeThn_X5umpjVSdbNSQIRI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_uY1_bHNTrAu2UuUwumZ6AuPc2Egu5fV5FiJ2-fv7ySk.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
.header-region-outer{background-color:#00A100;}@media screen and (min-width:1024px){.header-region-outer{background-image:url(http://mediad.publicbroadcasting.net/p/vpr/files/201711/v2artboard_2_copy_4_2.png);background-position:center;background-size:cover;background-repeat:repeat-x;}}.branding .tagline{color:#EDEFF0;}.branding .listen-live-toggle > a,.branding .header-utility > a,.branding .header-utility > a.trigger-nav{color:#EDEFF0;}@media screen and (min-width:641px){.branding .trigger-nav{background:#747679;}}@media screen and (max-width:640px){.branding .header-utility > a.trigger-nav,.active-menu .branding .header-utility > a.trigger-nav{color:#FFFFFF;}}#listen-live .listen-live-toggle{background-color:#747679;}#listen-live .listen-live-btn{background-color:transparent;color:#EDEFF0;}@media screen and (min-width:640px){#listen-live .listen-live-btn{background-color:#747679;}}.branding .give{background:#DB8916;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Lato:300,700,700italic,900,italic,regular&amp;subset=latin" media="all" />
<link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_VQHcCQs5WDuG7cQ2CerYlIHpmFaMkVU1BIc6rMgMgkY.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://digital.vpr.net/sites/digital.vpr.net/files/css/css_SWo6tZlpCPjnhbZDAS4xgnCAofi51J7pbtu4SD2fIug.css" media="all" />
    <script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js_xSpMA4ArVcBKOZ43sPqNRk0gxQZdDVifw27pIUCzWU0.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js_P9u0bgloveAIlc2kutVCUB_xMaRV3YHWhSVHD3IN5tM.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js_f_6-OzlFXjayKlsU5sJKLwjz7LFQvdIZDm-Mt6jKwyM.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js__4npt0PuTlrK-GkTl821OR8Eb7aiGB9GvsSeu1tr7U4.js"></script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js_ki6GNd1BPyxIvcU3OkdnVSER4OFNpi2OePujcSaPIRo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src="//stream.publicbroadcasting.net/analytics/aayb.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/vpr/files/js/js_cH3U7IH9aldihPlBdCkBRSSD2LoprOoqkmoG6LmFpeM.js"></script>
<script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width">
  </head>

  <body class="html not-front not-logged-in page-node page-node- page-node-46106 node-type-post" >
    <header role="banner" class="header">
  <div class="skiptocontent"><a href="#main-content">skip to main content</a></div>
    <div class="region region-header">
    <div id="block-baby-bear-baby-bear-header" class="block block-baby-bear">

    
  <div class="content">
    
<div class="header-region-outer">
  <section class="header-region-inner row">
    <div class="branding large-12 columns">
      <div class="brand-inner-wrapper">
        <a href="http://digital.vpr.net/" rel="home" class="logo" title="Vermont Public Radio Home"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/201411/logo.png" alt="Vermont Public Radio logo" title="Vermont Public Radio Home" /></a>         <div class="tagline">
                  </div>
      </div>
      <div class="header-utility">
        <a class="trigger-nav" href="#">
          <span class="icon-list"></span>
          <span class="menu-text">Site Menu</span>
        </a>
        <a class="give" href="https://donate.vpr.net/?utm_source=donate-button&utm_medium=website&utm_content=&utm_campaign=ongoing" >
  Donate</a>
      </div>
    </div>
  </section>
</div>
  </div>
</div>
  </div>
</header>
    <div class="nav-wrapper mobile">
      <nav>
        <div class="top-bar contain-to-grid" data-topbar>
          <ul class="title-area">
            <li class="toggle-topbar menu-icon">
              <a href="#">Menu</a>
            </li>
          </ul>
          <section class="top-bar-section">
            <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="http://digital.vpr.net">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/listen-radio-podcasts">Radio &amp; Podcasts</a>
<ul  class="dropdown">
<li class="left">
<a href="/online-streams">Online Streams</a>
</li>
<li class="left">
<a href="/schedule">Radio Schedules</a>
</li>
<li class="left">
<a href="/radio-stations-coverage-maps">Stations &amp; Coverage Maps</a>
</li>
<li class="left">
<a href="/programs">Program Directory</a>
</li>
<li class="left">
<a href="http://www.vpr.net/apps/podcasts/">Podcast Directory</a>
</li>
<li class="left">
<a href="/local-programs">VPR Produced Programs</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://digital.vpr.net/topic/vpr-news">VPR News</a>
<ul  class="dropdown">
<li class="left">
<a href="/newscasts">Newscasts</a>
</li>
<li class="left">
<a href="/programs/commentary-series">Commentaries</a>
</li>
<li class="left">
<a href="/topic/vermont-legislature">Vermont Legislature</a>
</li>
<li class="left">
<a href="/term/vpr-series-and-specials">Series &amp; Specials</a>
</li>
</ul>
</li>
<li>
<a href="/programs/vermont-edition">Vermont Edition</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs/vpr-classical">VPR Classical</a>
<ul  class="dropdown">
<li class="left">
<a href="http://www.vpr.net/apps/composer/playlist-calendar">Classical Playlists</a>
</li>
<li class="left">
<a href="/schedule/week/vpr-classical">Radio Schedule</a>
</li>
<li class="left">
<a href="/term/live-performances">Live Performances</a>
</li>
<li class="left">
<a href="/programs/genre/music">All Music Programs</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/support">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://donate.vpr.net">Join Or Renew Your Membership</a>
</li>
<li class="left">
<a href="/sustaining-membership">Sustaining Membership</a>
</li>
<li class="left">
<a href="http://www.vpr.net/support/business_underwriting/">Business Underwriting</a>
</li>
<li class="left">
<a href="/producers-circle">Producers Circle</a>
</li>
<li class="left">
<a href="/support">All Ways To Support VPR &gt;&gt;</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/inside-vpr">Inside VPR</a>
<ul  class="dropdown">
<li class="left">
<a href="/contact-vpr">Contact VPR</a>
</li>
<li class="left">
<a href="/people/capacity/staff">VPR Staff</a>
</li>
<li class="left">
<a href="/topic/vpr-blog">VPR Blog</a>
</li>
<li class="left">
<a href="/careers-vpr">Careers At VPR</a>
</li>
<li class="left">
<a href="/inside-vpr">More Inside VPR &gt;&gt; </a>
</li>
</ul>
</li>
<li>
<a href="http://digital.vpr.net/search/google">Search</a>
</li>
</ul>
</div>
          </section>
        </div>
      </nav>
    </div>
      <div class="region region-persistent">
    <div id="block-audity-audity" class="block block-audity">

    
  <div class="content">
      </div>
</div>
  </div>
    <div id="page-wrapper">
            <div id="page-document" role="document" class="page">
  <div class="nav-wrapper">
    <nav>
      <div class="top-bar contain-to-grid" data-topbar>
        <ul class="title-area">
          <li class="toggle-topbar menu-icon">
            <a href="#">Menu</a>
          </li>
        </ul>
        <section class="top-bar-section">
          <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="http://digital.vpr.net">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/listen-radio-podcasts">Radio &amp; Podcasts</a>
<ul  class="dropdown">
<li class="left">
<a href="/online-streams">Online Streams</a>
</li>
<li class="left">
<a href="/schedule">Radio Schedules</a>
</li>
<li class="left">
<a href="/radio-stations-coverage-maps">Stations &amp; Coverage Maps</a>
</li>
<li class="left">
<a href="/programs">Program Directory</a>
</li>
<li class="left">
<a href="http://www.vpr.net/apps/podcasts/">Podcast Directory</a>
</li>
<li class="left">
<a href="/local-programs">VPR Produced Programs</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://digital.vpr.net/topic/vpr-news">VPR News</a>
<ul  class="dropdown">
<li class="left">
<a href="/newscasts">Newscasts</a>
</li>
<li class="left">
<a href="/programs/commentary-series">Commentaries</a>
</li>
<li class="left">
<a href="/topic/vermont-legislature">Vermont Legislature</a>
</li>
<li class="left">
<a href="/term/vpr-series-and-specials">Series &amp; Specials</a>
</li>
</ul>
</li>
<li>
<a href="/programs/vermont-edition">Vermont Edition</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs/vpr-classical">VPR Classical</a>
<ul  class="dropdown">
<li class="left">
<a href="http://www.vpr.net/apps/composer/playlist-calendar">Classical Playlists</a>
</li>
<li class="left">
<a href="/schedule/week/vpr-classical">Radio Schedule</a>
</li>
<li class="left">
<a href="/term/live-performances">Live Performances</a>
</li>
<li class="left">
<a href="/programs/genre/music">All Music Programs</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/support">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://donate.vpr.net">Join Or Renew Your Membership</a>
</li>
<li class="left">
<a href="/sustaining-membership">Sustaining Membership</a>
</li>
<li class="left">
<a href="http://www.vpr.net/support/business_underwriting/">Business Underwriting</a>
</li>
<li class="left">
<a href="/producers-circle">Producers Circle</a>
</li>
<li class="left">
<a href="/support">All Ways To Support VPR &gt;&gt;</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/inside-vpr">Inside VPR</a>
<ul  class="dropdown">
<li class="left">
<a href="/contact-vpr">Contact VPR</a>
</li>
<li class="left">
<a href="/people/capacity/staff">VPR Staff</a>
</li>
<li class="left">
<a href="/topic/vpr-blog">VPR Blog</a>
</li>
<li class="left">
<a href="/careers-vpr">Careers At VPR</a>
</li>
<li class="left">
<a href="/inside-vpr">More Inside VPR &gt;&gt; </a>
</li>
</ul>
</li>
<li>
<a href="http://digital.vpr.net/search/google">Search</a>
</li>
</ul>
</div>
        </section>
      </div>
    </nav>
  </div>

  <div id="player" class="player">
      </div>

  
      <section class="pre-content">
      <div>
          <div class="region region-pre-content">
    <div id="block-pi-responsive-ads-mobile-1" class="block block-pi-responsive-ads">

    
  <div class="content">
      </div>
</div>
  </div>
      </div>
    </section>
  
  
  
  <div class="row">
    <main id="content" role="main" class="main-content small-12 columns">
      <article class="story">
        <a id="main-content"></a>
        
                                    
        
        
        
        
        
        
                  <div class="has-sidebar">
              <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-46106" class="node node-post node-promoted full row" about="/post/mitchs-sports-red-sox-power-surge-continues-knights-defy-odds-make-cup-final-inaugural-year" typeof="sioc:Item foaf:Document">
  <div class="small-12 columns">
        
          <div class='post-program post-program-top'>
        <div class="field field-name-field-related-program field-type-node-reference field-label-inline clearfix"><div class="field-label">Related Programs:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/programs/mitchs-sports-report">Mitch&#039;s Sports Report</a></div><div class="field-item odd"><a href="/programs/vpr-news">VPR News</a></div></div></div>      </div>
    
    <h1 itemprop="name" class="post-title">
      Mitch&#039;s Sports: Red Sox Power Surge Continues; Knights Defy Odds To Make Cup Final In Inaugural Year    </h1>

  	
    
          <div class="by-date">
        <span class="submitted"><span property="dc:date dc:created" content="2018-05-21T11:20:48-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/mitch-wertlieb" rel="author">Mitch Wertlieb</a></span></span></span>
        <i class="bullet">&#8226;</i>
        <span class="pub-date">2 hours ago</span>
      </div>
    
    <div class="row">
      <div class="large-2 columns sharing-and-programs">
                  <div class='post-program post-program-side'>
            <div class="field field-name-field-related-program field-type-node-reference field-label-inline clearfix"><div class="field-label">Related Programs:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/programs/mitchs-sports-report">Mitch&#039;s Sports Report</a></div><div class="field-item odd"><a href="/programs/vpr-news">VPR News</a></div></div></div>          </div>
        
        <div class="social-share clearfix"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq&amp;text=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq&amp;t=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq" class="social-share-item email" title="Email" target="_blank">Email</a></div>      </div>

      <div class="large-10 columns post-body-container" >
        <div class="post-body">
          <div class="field field-name-field-image-gallery field-type-image field-label-hidden"><div class="field-items"></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>  <div class="audio-container">   <div id="jp-interface--5b02e3d44fcb3" class="jp-interface">     <div id="post-audio--5b02e3d44fcb3" class="jp-player" jp-instance="-5b02e3d44fcb3"></div>      <div class="playpause">       <a href="https://cpa.ds.npr.org/vpr/audio/2018/05/vpr-sports-report-20180521.mp3" title="" class="jp-play"></a>      <a class="jp-pause"></a>     </div>      <div class="audio-meta">       <div class="listen-text-box">         <div class="listen-text">Listen </div>         <div class="listening-text">Listening...</div>       </div>        <div class="jp-controls">         <div class="jp-progress">           <div id="seekbar" class="jp-seek-bar">             <div id="playbar" class="jp-play-bar">               <div class="scrubber">               </div>             </div>           </div>         </div>       </div>        <div class="duration-wrapper">         <div class="jp-custom-current-time"></div>         <span class="divider">&#47;</span>         <div class="jp-custom-duration">5:52</div>       </div>      </div>       </div> </div>  </p> <p>If there were any doubts as to whether the Boston Red Sox have solved their power woes from 2017, when they were last in home runs in the American League, consider this: Through the first 47 games of the season, the 2018 Boston Red Sox have hit more home runs than any Red Sox team in then history of the franchise.</p> <p><!--break--></p> <p>One of the players making that stat a reality is J.D. Martinez, the slugger signed as a free agent in the off season who's launching baseballs into the stands in all directions. He had two dingers yesterday in Boston's 5-0 win over the Baltimore Orioles, his first home run a Pesky Pole special, a floater that twisted just inside the right field foul pole named after former Red Sox short stop Johnny Pesky. That's a routine pop fly in nearly any other ballpark but with the pole jutting out just about 308 feet from home plate a ball can get out if it's angled just right and Martinez got some ribbing from his teammates for getting a four-bagger of the variety more associated with singles hitters, but the same players who were kidding him about that homer were left with their jaws agape later in the game when Martinez hit his second home run of the game, a mammoth blast to the very deepest part of Fenway, over the 408 foot triangle area and into the bleachers, a tremendous home run and J.D.'s 15th of the year, which has him tied for the major league lead with his teammate Mookie Betts.</p> <p>Andrew Benintendi also went yard with a two run blast and Eduardo Rodriguez got the win, a curious one given that the Orioles had 13 hits on the afternoon and yet didn't score a run. E-Rod gave up nine of those hits, but he scattered them. A single here, a single there, seven strike-outs over five and two thirds innings, and before you know it, E-Rod had his fourth win of the year.</p> <p>The Red Sox are now headed on the road for a series against the suddenly hot Tampa Bay Rays, who had won six in a row before losing to the Angels yesterday.</p> <p>The NY Yankees are on cruise control as well, keeping pace with the Red Sox for first place in the A.L. east after a 10-1 romp over the Royals in Kansas City yesterday. Despite the power surge, the biggest positive for the Yankees was the best pitching performance of the year for Sonny Gray, who went eight innings to get the win. Gray had been scuffling as the one weak link in the Yankees pitching chain this season, but he dominated the Royals yesterday, striking out five and walking just one in his eight frames. Tyler Austin hit a pair of two-run homers to lead the relentless Yankee offense, who take their modern day murderer's row line-up to Texas to face the Rangers tonight.</p> <p>The NY Mets like what they see from promising rookie Amed Rosario, including the two home runs he hit yesterday in a 4-1 win over the Arizona Diamondbacks. Rosario is just 22 years old and becomes the youngest Met to hit multiple homers in the same game since Lastings Milledge did it in 2007. Noah Syndergaard got the win, his fourth of the year, striking out seven.</p> <p>To the NHL Stanley Cup playoffs, and what's happening in Vegas is most definitely not staying there. The Las Vegas Golden Knights, an expansion team, newly minted in the NHL, in their very first season of existence are going to the Stanley Cup finals after beating the Winnipeg Jets 2-1 yesterday to take the western conference finals in five games. Ryan Eaves, a player who was taken in the supplemental draft and acquired in a trade, tipped home the game winner.</p> <p>Now, first, a little perspective. Yes, this is an expansion team, and yes, what they are doing is amazing and worthy if praise. But this is also an NHL team stocked with veteran players from virtually every team in the league, including goalie Marc Andre-Fleury, who has three Stanley Cup rings already from his years backstopping the Pittsburgh Penguins. He just happens to be playing as well or better now than he did with Pittsburgh, and made 31 saves to get the series clinching win yesterday. James Neal is on the team, a power forward and prolific goal scorer many teams would love to have. The Knights were allowed to pluck two players that had to be left unprotected from each team so they could stock their roster, and what's happened is that those players deemed expendable by their old teams are having career seasons and playing with a chip, perhaps a poker chip given the team's locale, on their collective shoulders. But these expansion Knights are nowhere near as hapless as say, the California Golden Seals, who entered the league in the first great expansion in 1967 and were doormats for the rest of the league.</p> <p>This appearance in the Stanley Cup Finals form an expansion team is also not unprecedented. The St. Louis Blues made the finals in their first year of existence, but to be fair to Vegas, that was in a year when eight of 12 teams made the playoffs and all the expansion teams were in the same conference with each other, so a path to the playoffs and finals was much easier. When the Blues did reach the finals, they were swept easily by the Montreal Canadiens.</p> <p>That's not going to happen with this Vegas team. I'd prefer that they paid their dues a bit, but even though we don't know yet if they're going to play Washington or Tampa Bay, it doesn't matter. No way do these Knights get this far without winning it all. They're a team of destiny, defying all the odds that the makers set for them in their home city when the season began.</p> <p>NBA western conference finals, the Golden State Warriors regrouped after a game 2 loss to Houston, and pasted the Rockets 126-85 to take a two games to one lead behind 35 points from Steph Curry.</p> <p> Rafael Nadal won  the Italian Open tennis tournament and will enter the French Open as the #1 men's player in the world.</p> <p>After nearly a decade behind the bench as the head coach for the girl's high school basketball team at Rice Memorial high school, Tim Rice is stepping down from the post.</p> <p>The Burlington Free Press reports Rice is citing health concerns as his reason for retiring. Rice needed medical attention after collapsing during a game against CVU in February and in 2015 survived a similar incident at UVM. Under Rice's tenure the Green Knights captured back-to-back girl's Division I titles in 2011 and 2012.</p> <p> </p> </div></div></div><div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/term/sports" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Sports</a></div></div></div><div class="social-share bottom"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq&amp;text=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq&amp;t=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Mitch%27s%20Sports%3A%20Red%20Sox%20Power%20Surge%20Continues%3B%20Knights%20Defy%20Odds%20To%20Make%20Cup%20Final%20In%20Inaugural%20Year&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fybxz2xaq" class="social-share-item email" title="Email" target="_blank">Email</a></div><div id="disqus_thread"><noscript><p><a href="http://npr-vpr.disqus.com/?url=http%3A%2F%2Fdigital.vpr.net%2Fpost%2Fmitchs-sports-red-sox-power-surge-continues-knights-defy-odds-make-cup-final-inaugural-year">View the discussion thread.</a></p></noscript></div>        </div>

        <div class="related">
          <div class="field-name-field-related-posts"><h3>Related Content</h3>
<div id="node-46085" class="node-teaser node node-post node-promoted npr_river_card no-image contains-audio row" about="/post/mitchs-sports-price-throws-complete-game-gem-red-sox-more-home-ice-disadvantage-capitals" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/mitchs-sports-price-throws-complete-game-gem-red-sox-more-home-ice-disadvantage-capitals"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/mitchs-sports-price-throws-complete-game-gem-red-sox-more-home-ice-disadvantage-capitals">Mitch&#039;s Sports: Price Throws Complete Game Gem For Red Sox; More Home Ice Disadvantage For Capitals</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2018-05-18T09:57:13-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/mitch-wertlieb" rel="author">Mitch Wertlieb</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">May 18,  2018 </span>
        </div>
          </div>

    <div class="content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>  <div class="audio-container">   <div id="jp-interface--5b0308b9b90ec" class="jp-interface">     <div id="post-audio--5b0308b9b90ec" class="jp-player" jp-instance="-5b0308b9b90ec"></div>      <div class="playpause">       <a href="https://cpa.ds.npr.org/vpr/audio/2018/05/vpr-sports-report-20180518.mp3" title="" class="jp-play"></a>      <a class="jp-pause"></a>     </div>      <div class="audio-meta">       <div class="listen-text-box">         <div class="listen-text">Listen </div>         <div class="listening-text">Listening...</div>       </div>        <div class="jp-controls">         <div class="jp-progress">           <div id="seekbar" class="jp-seek-bar">             <div id="playbar" class="jp-play-bar">               <div class="scrubber">               </div>             </div>           </div>         </div>       </div>        <div class="duration-wrapper">         <div class="jp-custom-current-time"></div>         <span class="divider">&#47;</span>         <div class="jp-custom-duration">4:44</div>       </div>      </div>       </div> </div>  </p> <p>If David Price keeps pitching for the Boston Red Sox like he did against the Baltimore Orioles at Fenway Park last night, no one's going to care how much time he spends playing video games.</p> <p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-46064" class="node-teaser node node-post node-promoted npr_river_card no-image contains-audio row" about="/post/mitchs-sports-martinez-helps-red-sox-avoid-sweep-expansion-knights-expand-lead-over-jets" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/mitchs-sports-martinez-helps-red-sox-avoid-sweep-expansion-knights-expand-lead-over-jets"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/mitchs-sports-martinez-helps-red-sox-avoid-sweep-expansion-knights-expand-lead-over-jets">Mitch&#039;s Sports: Martinez Helps Red Sox Avoid A&#039;s Sweep; Expansion Knights Expand Lead Over Jets  </a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2018-05-17T10:37:17-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/mitch-wertlieb" rel="author">Mitch Wertlieb</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">May 17,  2018 </span>
        </div>
          </div>

    <div class="content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>  <div class="audio-container">   <div id="jp-interface--5b0308b9c15a4" class="jp-interface">     <div id="post-audio--5b0308b9c15a4" class="jp-player" jp-instance="-5b0308b9c15a4"></div>      <div class="playpause">       <a href="https://cpa.ds.npr.org/vpr/audio/2018/05/vpr-sports-report-20180517.mp3" title="" class="jp-play"></a>      <a class="jp-pause"></a>     </div>      <div class="audio-meta">       <div class="listen-text-box">         <div class="listen-text">Listen </div>         <div class="listening-text">Listening...</div>       </div>        <div class="jp-controls">         <div class="jp-progress">           <div id="seekbar" class="jp-seek-bar">             <div id="playbar" class="jp-play-bar">               <div class="scrubber">               </div>             </div>           </div>         </div>       </div>        <div class="duration-wrapper">         <div class="jp-custom-current-time"></div>         <span class="divider">&#47;</span>         <div class="jp-custom-duration">5:09</div>       </div>      </div>       </div> </div>  </p> <p>The Boston Red Sox had their ace on the mound, but he was uncharacteristically wild, so the Red Sox turned to their prized free agent acquisition to avoid what would have been their first series sweep of 2018.</p> <p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-46021" class="node-teaser node node-post node-promoted npr_river_card no-image contains-audio row" about="/post/mitchs-sports-report-marcus-morris-came-king-and-he-did-not-miss-celtics-rout-cavs" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/mitchs-sports-report-marcus-morris-came-king-and-he-did-not-miss-celtics-rout-cavs"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/mitchs-sports-report-marcus-morris-came-king-and-he-did-not-miss-celtics-rout-cavs">Mitch&#039;s Sports Report: Marcus Morris Came For The King And He Did Not Miss In Celtics Rout Of Cavs</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2018-05-14T09:45:44-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/mitch-wertlieb" rel="author">Mitch Wertlieb</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">May 14,  2018 </span>
        </div>
          </div>

    <div class="content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>  <div class="audio-container">   <div id="jp-interface--5b0308b9c99ff" class="jp-interface">     <div id="post-audio--5b0308b9c99ff" class="jp-player" jp-instance="-5b0308b9c99ff"></div>      <div class="playpause">       <a href="https://cpa.ds.npr.org/vpr/audio/2018/05/vpr-sports-report-20180514.mp3" title="" class="jp-play"></a>      <a class="jp-pause"></a>     </div>      <div class="audio-meta">       <div class="listen-text-box">         <div class="listen-text">Listen </div>         <div class="listening-text">Listening...</div>       </div>        <div class="jp-controls">         <div class="jp-progress">           <div id="seekbar" class="jp-seek-bar">             <div id="playbar" class="jp-play-bar">               <div class="scrubber">               </div>             </div>           </div>         </div>       </div>        <div class="duration-wrapper">         <div class="jp-custom-current-time"></div>         <span class="divider">&#47;</span>         <div class="jp-custom-duration">4:44</div>       </div>      </div>       </div> </div>  </p> <p>Fans of the David Simon show "The Wire" will no doubt recall the words of Omar, the self-proclaimed king of the mean streets of West Baltimore, who warned his enemies that "If you come for the King, you best not miss."</p> <p></p></div></div></div>    </div>

      </div>
</div>
</div>        </div>
      </div>
    </div>
      </div>
</div>
  </div>
</div>
  </div>

            <!-- In line style code is temporary -->
            <div class="sidebar">
              <div class="sidebar-content"></div>
            </div>
          </div>
              </article>
    </main>
  </div>

  
  <div class="bottom-ads">
    <div class="bottom-ads-inner"></div>
  </div>
</div>

<footer class="footer" role="contentinfo">
  <div class="row">
    <div class="footer-affiliate-container small-centered columns">
                  <div class="region region-footer">
    <div id="block-pi-table-queue-partnerfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-partnerfooter">
  <p class="partnerslabel">
  </p>
<div class="item-list"><ul class="partner-logos"><li class="first"><a href="http://ww.npr.org" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/styles/partner_footer_logo/public/201512/npr-logo.png" alt="NPR" title="NPR" /></a></li>
<li><a href="http://www.bbc.co.uk/worldserviceradio" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/styles/partner_footer_logo/public/201512/bbc-logo.png" alt="BBC" title="BBC" /></a></li>
<li><a href="https://www.facebook.com/vpr.net" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/styles/partner_footer_logo/public/201512/FB-f-Logo__white_72.png" alt="Facebook" title="Facebook" /></a></li>
<li><a href="https://twitter.com/vprnet" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/styles/partner_footer_logo/public/201512/twitter-logo-60px.png" alt="Twitter" title="Twitter" /></a></li>
<li class="last"><a href="https://www.instagram.com/vprnet/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/vpr/files/styles/partner_footer_logo/public/201605/white_instagram.png" alt="Instagram" title="Instagram" /></a></li>
</ul></div></div>
  </div>
</div>
<div id="block-pi-table-queue-auxiliarylinksfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-auxiliarylinksfooter">
  <div class="item-list"><ul class="auxiliary-links"><li class="first"><span>&copy; 2018 Vermont Public Radio</span></li>
<li><a href="http://digital.vpr.net/copyright-policy" target="_self">Copyright Policy</a></li>
<li><a href="http://digital.vpr.net/eeo-reports-and-statement" target="_self">VPR EEO Reports And Statement</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvti " target="_self">Public Files: WVTI</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvxm " target="_self">WVXM</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/woxm" target="_self">WOXM</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvba" target="_self">WVBA</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvnk" target="_self">WVNK</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvtq" target="_self">WVTQ</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvtx" target="_self">WVTX</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvpr" target="_self">WVPR</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wrvt" target="_self">WRVT</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/woxr" target="_self">WOXR</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wnch" target="_self">WNCH</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvpa" target="_self">WVPA</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wbtn-fm " target="_self">WBTN-FM</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvps" target="_self">WVPS</a></li>
<li><a href="https://publicfiles.fcc.gov/fm-profile/wvxr" target="_self">WVXR</a></li>
<li class="last">For assistance accessing our public files, please contact publicfile@vpr.net or call 802-654-4301</li>
</ul></div></div>
  </div>
</div>
  </div>
          </div>
  </div>
</footer>
      <script type="text/javascript">
<!--//--><![CDATA[//><!--
 (function ($) { $(document).foundation({ topbar: { custom_back_text: true, back_text: 'back', mobile_show_parent_link: true } }); }(jQuery));
//--><!]]>
</script>
    </div>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"15ba4da3e8","applicationID":"1108724","transactionName":"NlMBMhAECEZRAU1eDg8ZIgUWDAlbHwxWUwQ+RgIBBzoQXFUV","queueTime":0,"applicationTime":689,"atts":"GhQCRFgeG0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
